Home Forums
10 | 19 | 2021
We have 2320 guests and 2 members online
JoomlaNook Forums
Welcome, Guest
Please Login or Register.    Lost Password?
Go to bottom Favoured: 1
TOPIC: VirtueMart
#765
klowther
Admin
Posts: 3118
User Offline Click here to see the profile of this user
Gender: Male JoomlaNook Location: Fremont, NE USA Birthday: 07/23
Re:VirtueMart 13 Years, 1 Month ago  
Hi Sasa,

I looked at your page and have an idea what the problem is. Here is your imageslist.txt file:

img="images/stories/product1image.jpg" imgtitle="zlatna jabuka.jpg" imgalt="alt" url="http://fiansa.kilu.de/index.php?page=shop.produ...tproduct1.html"

The part in red is the name of your image file that will be used by imageflow to create the thumbnail that displays in the gallery. I looked on your site and could not find an image by the name that you have specified here. Imageflow will not display anything for this line because the image doesn't exist.

The part in green appears to be an error an should be removed.

Also, in order to use the url= keyword, you need to specify a output template of modules/mod_imageflow/templates/urllinktemplate.txt. This should go in the output template file paramter. This parameter is in the advanced parameters section.

Hope that helps.

- Ken
 
Logged Logged
  The administrator has disabled public write access.
#775
inkjunkie1
Posts: 3
User Offline Click here to see the profile of this user
Re:VirtueMart 13 Years, 1 Month ago  
Ken,

I am having issues with configuring the imageflow module to link to specific articles. I configured the module to work with a list file and it does draw image information from the file but won't link to the proper url. It always links to the url of the original image file and not the url of the article (the article links are the one's I write as url="..." in the list file, right?). Below are the setup steps I have taken so far:

I set up the list file homeflashlist.txt,
put it in the directory /modules/mod_imageflow/homeflashlist.txt,
set the output template address as /modules/mod_imageflow/templates/urllinktemplate.txt,
and my list file looks like the following:

img="/images/stories/all/arhauscasamachair.jpg" imgalt="Image 4" imgtitle="Imgtitle 4" url="inkjunkie.com/index.php?option=com_conte...&Itemid=74"

Am I missing any setup steps?

Great module by the way. I see many possibilities for it if I can just get the urls to link properly. Thanks for your help on this.

Maybe one suggestion, you could develop a component that would allow the site admin to update links and pictures in the imageflow modules.

-Mike
 
Logged Logged
  The administrator has disabled public write access.
#776
klowther
Admin
Posts: 3118
User Offline Click here to see the profile of this user
Gender: Male JoomlaNook Location: Fremont, NE USA Birthday: 07/23
Re:VirtueMart 13 Years, 1 Month ago  
Hi Mike,

The only thing I see right off the top is your url specificaions all have a leading / character. For example, you have the output template parameter as /modules/mod_imageflow/templates/urllinktemplate.txt. It needs to be modules/mod_imageflow/templates/urllinktemplate.txt. Same for the img= paremeter in the image list file.

Give that a try and let me know how it went.

- Ken
 
Logged Logged
  The administrator has disabled public write access.
#779
inkjunkie1
Posts: 3
User Offline Click here to see the profile of this user
Re:VirtueMart 13 Years, 1 Month ago  
Ken,

I removed all the leading / characters and still get the same result. Its puzzling because the module is pulling the images from the listfile i created but is sending me to the img= address and not the url= address when I click on an image.

Any thoughts?

-Mike
 
Logged Logged
  The administrator has disabled public write access.
#780
klowther
Admin
Posts: 3118
User Offline Click here to see the profile of this user
Gender: Male JoomlaNook Location: Fremont, NE USA Birthday: 07/23
Re:VirtueMart 13 Years, 1 Month ago  
Mike,

Could you email me a link so that I may have a look at the page?

This e-mail address is being protected from spambots. You need JavaScript enabled to view it

Thanks,

- Ken
 
Logged Logged
  The administrator has disabled public write access.
#781
klowther
Admin
Posts: 3118
User Offline Click here to see the profile of this user
Gender: Male JoomlaNook Location: Fremont, NE USA Birthday: 07/23
Re:VirtueMart 13 Years, 1 Month ago  
Mike,

I've looked at your site and it appears that it is not picking up your output template specification for some reason. When it can't find the specified output template, it uses an internal default configuration for highslide.

I was able to verify that the urllinktemplate.txt file where it is supposed to be and it's contents look correct. Please verify again that the output template parameter is specified as modules/mod_imageflow/templates/urllinktemplate.txt

- Ken
 
Logged Logged
  The administrator has disabled public write access.
Go to top