Home Forums
10 | 19 | 2021
JoomlaNook Forums
Welcome, Guest
Please Login or Register.    Lost Password?
Set target to _blank, or link to article
(0 viewing) 
Go to bottom
TOPIC: Set target to _blank, or link to article
#2977
Merlyn
Posts: 9
User Offline Click here to see the profile of this user
Gender: Female Location: Netherlands
Set target to _blank, or link to article 12 Years ago  
Hello,

Being a complete newbee to Imageflow, I have a question.
I put an imageflow on my site. Works fine.
But I don't want to load the large images to _self but to _blank instead.
How can I do this?

And I'm trying to figure out how the List Fiel works, but can't find how to link to an article instead of to a large image.

In case you're interested, here's my imageflow: www.fransdingemanse.nl/index.php/fotogalerij

Thanks!!
 
Logged Logged
  The administrator has disabled public write access.
#2978
klowther
Admin
Posts: 3118
User Offline Click here to see the profile of this user
Gender: Male JoomlaNook Location: Fremont, NE USA Birthday: 07/23
Re:Set target to _blank, or link to article 12 Years ago  
Hi,But I don't want to load the large images to _self but to _blank instead.
How can I do this?
You can add target="_blank" to the output template that you are using. If you are currently using the default output template, you will need to edit the highslidetemplate.txt file in the template directory and change the following:

<a class="highslide" href="{img}" onclick="return hs.expand(this)" title="{hreftitle}">
<img src="{rflct}" alt="{imgalt}" title="{imgtitle}"/></a>

To:

<a class="highslide" href="{img}" target="_blank" onclick="return hs.expand(this)" title="{hreftitle}">
<img src="{rflct}" alt="{imgalt}" title="{imgtitle}"/></a>

Then in the the advanced parameters of the imageflow module specify "modules/mod_imageflow/templates/highslidetemplate.txt

And I'm trying to figure out how the List Fiel works, but can't find how to link to an article instead of to a large image.To link to an article use the urllinktemplate.txt output template. In the image list file you would specify:

img="imagefile" url="article link" tmplt="modules/mod_imageflow/templates/urllinktemplate.txt"

I took a look at your webpage. The only suggestion I have is regarding the generated thumbnails. They would probably look better if you either change the 'Fade to color' parameter value to match the background color of your page OR set the 'Transparent reflections' parameter to 'Yes'.

Hope that helps.

- Ken
 
Logged Logged
  The administrator has disabled public write access.
#2980
Merlyn
Posts: 9
User Offline Click here to see the profile of this user
Gender: Female Location: Netherlands
Re:Set target to _blank, or link to article 12 Years ago  
Hi Ken,

First of all: thanks for your reply!
And thanks for the suggestion regarding the thumbnails.

I just have a problem using the right syntax in urllinktemplate.txt

I first put
Code:

img="images/stories/schilderijen/achterkant.jpg" url="index.php/achterkant" tmplt="modules/mod_imageflow/templates/urllinktemplate.txt"
, but that didn't do the trick,
so then I followed the syntax as displayed in the file and put it like this:
Code:

// 
//output template suitable for linking to any url 
//The following parameters will be inserted into the resulting output: 
// {img} = URL of the image 
// {hreftitle} = title specification from imagelistfile 
// {rflct} = URL of thumbnail/reflection image 
// {imgalt} = image alt specification from imagelistfile or filename if loading from a directory 
// {imgtitle} = image title specification from imagelistfile. 
// {url} = user provided url 
//  <a href="{url}" title="{hreftitle}"> <img src="{rflct}" alt="{imgalt}" title="{imgtitle}"/></a>

rflct="images/stories/schilderijen/achterkant.jpg" 
url="index.php/achterkant" 
hreftitle="Achterkant"
imgalt="Achterkant"
imgtitle="Achterkant"
tmplt="modules/mod_imageflow/templates/urllinktemplate.txt"



But that results in: this.....

Mathilde
 
Logged Logged
  The administrator has disabled public write access.
#2983
klowther
Admin
Posts: 3118
User Offline Click here to see the profile of this user
Gender: Male JoomlaNook Location: Fremont, NE USA Birthday: 07/23
Re:Set target to _blank, or link to article 12 Years ago  
Hi,I just have a problem using the right syntax in urllinktemplate.txtThe change I suggested for linking to an article was to be put in your image list file NOT the urllinktemplate.txt file.

- Ken
 
Logged Logged
 
Last Edit: 2009/10/05 07:15 By klowther.
  The administrator has disabled public write access.
#2987
Merlyn
Posts: 9
User Offline Click here to see the profile of this user
Gender: Female Location: Netherlands
Re:Set target to _blank, or link to article 12 Years ago  
sorry....

Did that.
Now my imagefilelist (schilderijenlist) is like this:
Code:

// // ImageFlow for Joomla images list // 

img="images/stories/schilderijen/achterkant.jpg"  
imgalt="Achterkant"
hreftitle="Achterkant" 
imgtitle="Achterkant" 

img="images/stories/schilderijen/automaat.JPG"  
imgalt="Automaat"
hreftitle="Automaat" 
imgtitle="Automaat" 



And I reset the urllinktemplate.txt to what it originally was.

I set 'Load images from' to Image file list
I set 'Image list file' to modules/mod_imageflow/schilderijenlist.txt
I set 'Output template' to modules/mod_imageflow/templates/urllinktemplate.txt

But now, no pictures show.....

Sorry, but as I said, I'm a newbee ans the documentation does not help me out on this.


Edit:
Changing tthe filelist to:
Code:

img="images/stories/schilderijen/achterkant.jpg" 
url="index.php/achterkant" 
tmplt="modules/mod_imageflow/templates/urllinktemplate.txt"



Does not help either.
 
Logged Logged
 
Last Edit: 2009/10/05 10:01 By Merlyn.
  The administrator has disabled public write access.
#2988
klowther
Admin
Posts: 3118
User Offline Click here to see the profile of this user
Gender: Male JoomlaNook Location: Fremont, NE USA Birthday: 07/23
Re:Set target to _blank, or link to article 12 Years ago  
Hi,

No need to apologize. I'm sorry that the documentation doesn't make everything clearer.

Okay, I see the main problem When you reset the urllinktemplate.txt file you inadvertantly commented out the html output template. Here is what it currently looks like:
Code:

// 
//output template suitable for linking to any url 
//The following parameters will be inserted into the resulting output: 
// {img} = URL of the image 
// {hreftitle} = title specification from imagelistfile 
// {rflct} = URL of thumbnail/reflection image 
// {imgalt} = image alt specification from imagelistfile or filename if loading from a directory 
// {imgtitle} = image title specification from imagelistfile. 
// {url} = user provided url 
//  <a href="{url}" title="{hreftitle}"> <img src="{rflct}" alt="{imgalt}" title="{imgtitle}"/></a>


You need to remove the 2 slashes from the last line.

Also, to use the urllinktemplate, you need to specify a url= parameter in the modules/mod_imageflow/schilderijenlist.txt file.

One more thing, in the modules/mod_imageflow/schilderijenlist.txt file, when you place the parameters on individual lines you must use the & character. So an entry in that file should look like this:

Code:


img="images/stories/schilderijen/achterkant.jpg" & 
imgalt="Achterkant" &
hreftitle="Achterkant" &
imgtitle="Achterkant" &
url="index.php?.....etc"



- Ken
 
Logged Logged
  The administrator has disabled public write access.
Go to top